Cisco Systems 78-11741-02 Wireless Office Headset User Manual


 
Configuring IP Routing Protocol-Independent Features
IP Routing Protocol-Independent Configuration Examples
IPC-393
Cisco IOS IP Configuration Guide
The passive-interface router configuration command is typically used when the wildcard specification
on the network router configuration command configures more interfaces than is desirable. The
following configuration causes OSPF to run on all subnets of 172.18.0.0:
interface ethernet 0
ip address 172.18.1.1 255.255.255.0
interface ethernet 1
ip address 172.18.2.1 255.255.255.0
interface ethernet 2
ip address 172.18.3.1 255.255.255.0
!
router ospf 1
network 172.18.0.0 0.0.255.255 area 0
If you do not want OSPF to run on 172.18.3.0, enter the following commands:
router ospf 1
network 172.18.0.0 0.0.255.255 area 0
passive-interface ethernet 2
Default Passive Interface Example
The following example configures the network interfaces, sets all interfaces that are running OSPF as
passive, and then enables serial interface 0:
interface Ethernet 0
ip address 172.19.64.38 255.255.255.0 secondary
ip address 172.19.232.70 255.255.255.240
no ip directed-broadcast
!
interface Serial 0
ip address 172.24.101.14 255.255.255.252
no ip directed-broadcast
no ip mroute-cache
!
interface TokenRing0
ip address 172.20.10.4 255.255.255.0
no ip directed-broadcast
no ip mroute-cache
ring-speed 16
!
router ospf 1
passive-interface default
no passive-interface Serial0
network 172.16.10.0 0.0.0.255 area 0
network 172.19.232.0 0.0.0.255 area 4
network 172.24.101.0 0.0.0.255 area 4
Policy Routing Example
The following example provides two sources with equal access to two different service providers.
Packets that arrive on asynchronous interface 1 from the source 10.1.1.1 are sent to the router at
172.16.6.6 if the router has no explicit route for the destination of the packet. Packets that arrive from
the source 172.17.2.2 are sent to the router at 192.168.7.7 if the router has no explicit route for the
destination of the packet. All other packets for which the router has no explicit route to the destination
are discarded.
access-list 1 permit ip 10.1.1.1
access-list 2 permit ip 172.17.2.2
!