Cisco Systems 78-11741-02 Wireless Office Headset User Manual


 
Configuring IP Routing Protocol-Independent Features
IP Routing Protocol-Independent Configuration Examples
IPC-384
Cisco IOS IP Configuration Guide
redistribute bgp 50000
OSPF Routing and Route Redistribution Examples
OSPF typically requires coordination among many internal routers, ABRs, and Autonomous System
Boundary Routers (ASBRs). At a minimum, OSPF-based routers can be configured with all default
parameter values, with no authentication, and with interfaces assigned to areas. Three types of examples
follow:
The first examples are simple configurations illustrating basic OSPF commands.
The second example illustrates a configuration for an internal router, ABR, and ASBRs within a
single, arbitrarily assigned, OSPF autonomous system.
The third example illustrates a more complex configuration and the application of various tools
available for controlling OSPF-based routing environments.
Basic OSPF Configuration Examples
The following example illustrates a simple OSPF configuration that enables OSPF routing process 9000,
attaches Ethernet interface 0 to area 0.0.0.0, and redistributes RIP into OSPF and OSPF into RIP:
interface ethernet 0
ip address 172.16.1.1 255.255.255.0
ip ospf cost 1
!
interface ethernet 1
ip address 172.17.1.1 255.255.255.0
!
router ospf 9000
network 172.16.0.0 0.0.255.255 area 0.0.0.0
redistribute rip metric 1 subnets
!
router rip
network 172.17.0.0
redistribute ospf 9000
default-metric 1
The following example illustrates the assignment of four area IDs to four IP address ranges. In the
example, OSPF routing process 1 is initialized, and four OSPF areas are defined: 10.9.50.0, 2, 3, and 0.
Areas 10.9.50.0, 2, and 3 mask specific address ranges, whereas area 0 enables OSPF for all other
networks.
router ospf 1
network 172.16.20.0 0.0.0.255 area 10.9.50.0
network 172.16.0.0 0.0.255.255 area 2
network 172.17.10.0 0.0.0.255 area 3
network 0.0.0.0 255.255.255.255 area 0
!
! Ethernet interface 0 is in area 10.9.50.0:
interface ethernet 0
ip address 172.16.20.5 255.255.255.0
!
! Ethernet interface 1 is in area 2:
interface ethernet 1
ip address 172.16.1.5 255.255.255.0
!
! Ethernet interface 2 is in area 2:
interface ethernet 2
ip address 172.17.2.5 255.255.255.0